iunie 16, 2024

Obiectiv Jurnalul de Tulcea – Citeste ce vrei sa afli

Informații despre România. Selectați subiectele despre care doriți să aflați mai multe

Sunt disponibile upgrade-uri Ubuntu 24.04 – pentru utilizatorii Mantic • History

Sunt disponibile upgrade-uri Ubuntu 24.04 – pentru utilizatorii Mantic • History

Acest lucru vine puțin mai târziu decât de obicei, dar dacă utilizați Ubuntu 23.10 Mantic Minotaur, ar trebui să începeți să vedeți solicitări pentru a face upgrade la noua versiune.

Aceasta nu este prima întârziere în accesarea acestei versiuni. Ubuntu 24.04 Noble Numbat a fost lansat la sfârșitul lunii aprilie, după o scurtă perioadă de testare beta care a început târziu. Lansarea beta a fost amânată din cauza ușii din spatele bibliotecii xz care a avut loc la sfârșitul lunii martie.

Noble este o versiune de suport pe termen lung și nu va ajunge la sfârșitul vieții sale Până în iunie 2029După cum a anunțat Canonical în martie, va primi 12 ani de actualizări în loc de 10 ani – dacă utilizatorii aleg Ubuntu Pro, adică.

Dacă rulați LTS anterior, 22.04 Jammy Jellyfish, nu veți fi deranjat până la lansarea din 24.04.1, așteptată în august. Deci, deocamdată, notificările de actualizare se aplică doar versiunii din octombrie Mantic Minotaur. Canonul în sine Estimări 95% dintre utilizatorii Ubuntu rulează versiuni LTS, așa că majoritatea nu vor primi actualizările oferite încă.

Întârzierea livrării actualizării se datorează unor erori lipicioase pe care Canonical le-a descoperit în timpul testării sale. Noble schimbă clientul de e-mail implicit al Ubuntu, Thunderbird, la o versiune compilată în formatul surprinzător Canonical. Actualizarea pachetului Thunderbird de la Debian la pachetul Snap a scos la iveală unele probleme, inclusiv Eroare #2061918. Credem că, poate, din păcate, majoritatea oamenilor folosesc webmail în zilele noastre și probabil că nu deschid niciodată Thunderbird – chiar dacă ar trebui să o încerce. Cea mai mare problemă este că „Noble” se convertește în marcaje de timp Unix pe 64 de biți, ceea ce poate încurca umplerea APT – de exemplu, ca în Bug numărul 2063221.

READ  Australienii adună torțe ca parte a unei comunități internaționale iluminate

Classic Unix a folosit un număr de 32 de biți pentru a păstra marcajele de timp, ceea ce înseamnă că data maximă pe care o putea păstra era anul 2038 – așa-numita problemă Y2K38 pe care am explicat-o când BBC iPlayer a început să raporteze această dată. S-a rezolvat acum, dar nu fără cocoașa ocazională pe drum.

cel reg FOSS mi-a actualizat mașina Ubuntu 23.10 sacrificială ieri și, deși a durat câteva ore, a funcționat bine. Upgrade-ul a fost reinstalat snapd, pe care l-am scos de pe acest laptop, dar tocmai asta este de așteptat. Procedura este aceeași ca acum mai bine de un deceniu: faceți backup pentru orice lucru important, apoi instalați toate actualizările:

sudo apt update
sudo apt full-upgrade -y

Poate fi necesar să adăugați sudo snap refresh Și acolo, pentru orice eventualitate. Am descoperit că trebuie să actualizăm manual unele pachete care au fost „împiedicate” de ceea ce le numește Canonical Actualizări intermediare. Dacă ai și tu asta, încearcă sudo apt upgrade -y încă o dată. Dacă cutia ta există foarte Renegade, puteți copia și lipi lista de pachete reținute la sfârșitul fișierului sudo upgrade -y Linie – Nu uitați să editați orice întreruperi de linie.

Reporniți, apoi rulați managerul de actualizări (update-manager pentru tipurile de linie de comandă sau „Actualizări de software” pentru instrumentele de tip point-and-click) și ar trebui să vi se ofere actualizarea. Războinicii shell hardcore pot invoca do-release-upgrade. ®

Nota de subsol introductivă

Este posibil ca utilizatorii nobili să nu-l primească GNOME 46.1 Oricând în viitorul apropiat, oricum. GNOME este construit în jurul componentei Mutter window-manager-cum-Wayland, iar Mutter 46.1 include o componentă nouă Sincronizare explicită caracteristică. Versiunile raster ale GNOME sunt menite să remedieze erori și nu să introducă funcții noi, iar Canonical a făcut-o Politica de excepție a versiunilor minore Aceasta acoperă, sub care versiunile GNOME Points sunt transmise utilizatorilor LTS. Acum, spune unul din echipa de dezvoltare GNOME a încălcat acest lucru Cu versiunea 46.1

READ  iOS 15.0.1 adresează eroarea de deblocare Apple Watch

Se știe că lucrul cu GNOME nu este ușor. De aceea a apărut desktop-ul Unity, la fel ca Canonical SABDFL Mark Shuttleworth A fost scris pe atunciȘi alte distribuții sunt încă descoperite după mai bine de un deceniu.